您的位置:首页 > 其它

NYOJ 283 对称排序

2017-07-23 16:52 218 查看

对称排序

时间限制:1000 ms  |  内存限制:65535 KB难度:1描述In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 
输入The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, NOT SORTED. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long. 
输出For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
If length of two strings is equal,arrange them as the original order.(HINT: StableSort recommanded)
样例输入
7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0
样例输出
SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill
哇!这题真是哭唧唧了,首先题目是对称排序,一定要先排序,其次,定义字符型数组 输入字符串为什么不能从1开始记,害得我一直WA,真的是要死了,最后还是找出了毛病,所以还是很棒的!继续加油!
下面附上我改正过得代码嘻嘻嘻!
#include<stdio.h>
#include<string.h>
int main()
{
int n,b=1;
int i,j;
char s[15][26],temp[26];
while(scanf("%d",&n)!=EOF&&n)
{

for(i=0;i<n;i++)
{
scanf("%s",&s[i]);
}
for(i=0;i<n-1;i++)
{
for(j=0;j<n-1-i;j++)
{
if(strlen(s[j])>strlen(s[j+1]))
{
strcpy(temp,s[j]);
strcpy(s[j],s[j+1]);
strcpy(s[j+1],temp);
}
}
}
printf("SET %d\n",b++);
for(i=0;i<n;i+=2)
{
printf("%s\n",s[i]);
}
if(n%2!=0)
{
n=n-2;
}
else if(n%2==0)
{
n=n-1;
}
for(i=n;i>=1;i-=2)
{
printf("%s\n",s[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: