您的位置:首页 > 其它

【PAT】【Advanced Level】1031. Hello World for U (20)

2017-07-23 15:15 429 查看


1031. Hello World for U (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and
finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 =
max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lowor


原题链接:

https://www.patest.cn/contests/pat-a-practise/1031

思路:

按要求求出N1N2N3的值即可,加2除三得到N1N3,总数减去N1N3得到N2。

CODE:

#include<iostream>
#include<cstring>
#include<string>

using namespace std;

int main()
{
string a;
cin>>a;
int n=a.length();
int n1=(n+2)/3-1;
int n3=n1;
int n2=n-n1-n3;
//cout<<n1<<" "<<n2<<" "<<n3<<endl;
for (int i=0;i<n1;i++)
{
cout<<a[i];
for (int j=2;j<n2;j++) cout<<" ";
cout<<a[a.length()-1-i];
cout<<endl;
}
for (int i=0;i<n2;i++)
cout<<a[n1+i];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: