您的位置:首页 > 其它

HDU-1501-Zipper

2017-07-22 19:12 369 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1501


Zipper

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

 

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

 
 题目分析:给定三个字符串,判断第三个字符串是否为前两个之和,且字符串的顺序不变。 

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char s1[201],s2[201],s[402];
int len1,len2,len;
bool ans;
bool vis[201][201];
void dfs(int x,int y,int z)
{
if(x==len1&&y==len2&&z==len)
{
ans=1;
return ;
}
if(!vis[x][y])
{
vis[x][y]=1;
if(s1[x]!=s[z]&&s2[y]!=s[z])
return;
if(s1[x]==s[z])
dfs(x+1,y,z+1);
if(s2[y]==s[z])
dfs(x,y+1,z+1);
if(ans)
return;
}
}
int main(){
int n;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>s1>>s2>>s;
ans=0;
len=strlen(s);
len1=strlen(s1);
len2=strlen(s2);
memset(vis,0,sizeof(vis));
dfs(0,0,0);
if(ans)
cout<<"Data set "<<i<<": "<<"yes"<<endl;
else
cout<<"Data set "<<i<<": "<<"no"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: