您的位置:首页 > 其它

LightOJ 1005 - Rooks(组合数学解法,记忆化解法)

2017-07-22 17:40 363 查看



                               


                             Rooks

 LightOJ - 1005 

A rook is a piece used in the game of chess which is played on a board of square grids. A rook can only move vertically or horizontally from its current position and two rooks attack each other if one is on the path of the other. In the following figure,
the dark squares represent the reachable locations for rook R1 from its current position. The figure also shows that the rook R1 and R2 are in attacking positions where R1 and R3 are
not. R2 and R3 are also in non-attacking positions.



Now, given two numbers n and k, your job is to determine the number of ways one can put k rooks on an n x n chessboard so that no two of them are in attacking positions.

Input
Input starts with an integer T (≤ 350), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 30) and k (0 ≤ k ≤ n2).

Output
For each case, print the case number and total number of ways one can put the given number of rooks on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1017.

Sample Input
8

1 1

2 1

3 1

4 1

4 2

4 3

4 4

4 5

Sample Output
Case 1: 1

Case 2: 4

Case 3: 9

Case 4: 16

Case 5: 72

Case 6: 96

Case 7: 24

Case 8: 0



题意:相当于在一个n*n的棋盘上放k个车,并且互相不能吃,问有几种方法

组合数学
分析:任意两个不能同行不能同列,转换到线段上就是n行中选k行,n列中选k列,转换到二维就是将它们相乘
那么就是  A(n,k)*A(n,k)/A(k,k)=C(n,k)*A(n,k)

#include<stdio.h>
#include<string.h>
long long C(int a,int b)
{
long long c=1;
for(int i=a;i>a-b;i--)
c*=i;
long long d=1;
for(int i=1;i<=b;i++)
d*=i;
return c/d;
}
long long A(int a,int b)
{
long long c=1;
for(int i=a;i>a-b;i--)
c*=i;
return c;
}
int main()
{
int T,cas=0;
scanf("%d",&T);
while(T--)
{
printf("Case %d: ",++cas);
int n,k;
scanf("%d%d",&n,&k);
if(k>n)
printf("0\n");
else
printf("%lld\n",C(n,k)*A(n,k));
}
}


记忆化(dp)

分析:可以知道 在n*n的格子里放k个棋子,因为每个棋子占一行一列,那去掉一个棋子的话
就是 在(n-1)*(n-1)格子里放(k-1)个棋子,那么只需要看多出的棋子有多少方法就可以了

#include<stdio.h>
#include<string.h>
long long dp[33][999];
int main()
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=30;i++)
dp[i][0]=1,dp[i][1]=i*i;
for(int i=2;i<=30;i++)
{
for(int j=2;j<=i;j++)
dp[i][j]=dp[i][1]*dp[i-1][j-1]/j;
}
int T,cas=0;
scanf("%d",&T);
while(T--)
{
int n,k;
scanf("%d%d",&n,&k);
printf("Case %d: %lld\n",++cas,dp
[k]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: