您的位置:首页 > 其它

FZU Tic-Tac-Toe

2017-07-22 14:36 344 查看
Problem L Tic-Tac-Toe

Accept: 94    Submit: 184

Time Limit: 1000 mSec    Memory Limit : 262144 KB



 Problem Description

Kim likes to play Tic-Tac-Toe.

Given a current state, and now Kim is going to take his next move. Please tell Kim if he can win the game in next 2 moves if both player are clever enough.

Here “next 2 moves” means Kim’s 2 move. (Kim move,opponent move, Kim move, stop).



Game rules:

Tic-tac-toe (also known as noughts and crosses or Xs and Os) is a paper-and-pencil game for two players, X and O, who take turns marking the spaces in a 3×3 grid. The player who succeeds in placing three of their marks in a horizontal, vertical, or diagonal
row wins the game.



 Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Each test case contains three lines, each line three string(“o” or “x” or “.”)(All lower case letters.)

x means here is a x

o means here is a o

. means here is a blank place.

Next line a string (“o” or “x”) means Kim is (“o” or “x”) and he is going to take his next move.



 Output

For each test case:

If Kim can win in 2 steps, output “Kim win!”

Otherwise output “Cannot win!”



 Sample Input

3

. . .

. . .

. . .

o

o x o

o . x

x x o

x

o x .

. o .

. . x

o



 Sample Output

Cannot win!Kim win!Kim win!

代码有点糙,爆搜过,思路如下:
.为0,x为-1,o为1
设一个系数k,当我方为x的时候k为-1,为o时k为1.
判断行列斜和,若和为2直接true,和为1用cnt计数下来,当cnt大于等于2时候(其实2就可以了)也为true。
代码如下:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;

char map[4][4];
int s[4][4];
int t;
int sum;
int k;
int cnt;

bool judge(int x,int y){
if((x+y)%2==1){
cnt=0,sum=0;
for(int i=1;i<=3;i++){
sum+=s[i][y];
}
sum*=k;
if(sum==2)
return true;
else if(sum==1)
cnt++;
sum=0;
for(int i=1;i<=3;i++){
sum+=s[x][i];
}
sum*=k;
if(sum==2)
return true;
else if(sum==1)
cnt++;
if(cnt==2){
return true;
}
}
else {
cnt=0,sum=0;
for(int i=1;i<=3;i++){
sum+=s[i][y];
}
sum*=k;
if(sum==2)
return true;
else if(sum==1)
cnt++;
sum=0;
for(int i=1;i<=3;i++){
sum+=s[x][i];
}
sum*=k;
if(sum==2)
return true;
else if(sum==1)
cnt++;
sum=0;
if(x==y){
for(int i=1;i<=3;i++){
sum+=s[i][i];
}
sum*=k;

if(sum==2)
return true;
else if(sum==1)
cnt++;
}
else {
for(int i=1;i<=3;i++){
sum+=s[i][4-i];
}
sum*=k;

if(sum==2)
return true;
else if(sum==1)
cnt++;
}
if(cnt>=2){
return true;
}
}
return false;
}

int main(){
char st;
int flag;
scanf("%d",&t);
while(t--){
flag=0;
memset(s,0,sizeof(0));
for(int i=1;i<=3;i++){
for(int j=1;j<=3;j++){
cin>>map[i][j];
if(map[i][j]=='.')  s[i][j]=0;
else if(map[i][j]=='o') s[i][j]=1;
else if(map[i][j]=='x') s[i][j]=-1;
}
}
cin>>st;
if(st=='o') k=1;
else if (st=='x') k=-1;
for(int i=1;i<=3;i++){
for(int j=1;j<=3;j++){
if(map[i][j]=='.'){
if(judge(i,j))
flag=1;
}
}
}
if(flag) puts("Kim win!");
else    puts("Cannot win!");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: