您的位置:首页 > 其它

PAT (Advanced Level) Practise 1032 Sharing (25)

2017-07-22 10:41 417 查看


1032. Sharing (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1


题意:给你两个链表的头指针,给出n个节点,求出这两个链表第一个公共的区域

解题思路:枚举第一个链表,记录下哪些区域出现过,然后在去枚举第二个链表即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

struct node
{
int nt;
char ch[5];
}x[100009];
int s, ss, n,vis[100009];

int main()
{
while (~scanf("%d%d%d", &s, &ss, &n))
{
memset(x, -1, sizeof x);
memset(vis, 0, sizeof vis);
int id;
for (int i = 0; i < n; i++)
{
scanf("%d", &id);
scanf("%s%d", x[id].ch, &x[id].nt);
}
for (int i = s; ~i; i = x[i].nt) vis[i] = 1;
int ans = -1;
for (int i = ss; ~i; i = x[i].nt)
if (vis[i]) { ans = i; break; }
if(ans!=-1) printf("%05d\n", ans);
else printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: