您的位置:首页 > 其它

POJ 1611 The Suspects

2017-07-21 19:48 204 查看
                                                      The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 39352 Accepted: 19046
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student
is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the
number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


题目大意是说一种SARS的病毒爆发,学校里有一堆同学,要找出他们是不是感染嫌疑人,默认0号同学是感染者,与0号同学有接触的都有可能感染,包括那些接触了接触过0号同学的同学的同学(有点绕.....)请找出可能的感染者人数

用并查集

#include<iostream>
#include<cstdio>
using namespace std;
int tree[30010];
int find(int x){
return x==tree[x]?x:tree[x]=find(tree[x]);
}
void merge(int x,int y){
int a=find(x);
int b=find(y);
if(a!=b) tree[b]=a;
}
int main(){
int n,m;
while(~scanf("%d%d",&n,&m)){
if(!n&&!m) break;
for(int i=0;i<=n;i++) tree[i]=i;
while(m--){
int a,b,next;
cin>>a>>b;
if(a==1) continue;
for(int i=1;i<a;i++){
cin>>next;
merge(b,next);
}
}
int sum=0;
for(int i=0;i<=n;i++){
//
4000
0号同学不一定是祖先,但只要他们都是疑似的感染者,那么他们的祖先一定是相同的
if(find(tree[i])==find(tree[0]))
sum++;
}
cout<< sum <<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: