您的位置:首页 > 其它

不要什么都依赖数组

2017-07-21 10:44 183 查看
有些题目不用数组反而更简单   依次输入数据,每输入一个数据就对其进行操作,判断

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will
be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a numberAi denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or
more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input
There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line containsN integers
Ai (1 <= Ai <= 1000).

Output
For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input
3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output
2
Nobody
998


题目大意:有N组数据, 每组数据有n个数代表n个评委    每个评委都有一次投票机会可以投给他们喜欢的那一号选手,然后每个评委投一次票, 第一组输入示例  2 2 2 1 1  代表有三个评委投了二号选手,两个评委投了1号选手    所以自然2号选手胜出,第二组  1号 2号选手分别得两票   所以无法选出优胜者

提示:

依次输入n个数   每输入一个就对其进行操作, 判断    用数组反而相当相当麻烦

#include <cstdio>

#include <cstdlib>

#include <cmath>

#include <algorithm>

#include <iostream>

#include <cstring>

#include <vector>

#include <queue>

#include <stack>

#include <set>

#include <map>

#define LL long long

#define INF 0x3f3f3f3f

#define mem(a, b) memset(a, b, sizeof(a))

#define PI 3.1415926

using namespace std;

    int a[1001];

    int N;

    int main()

    {

        scanf("%d",&N);

        while(N--)

        {

            memset(a,0,sizeof(a));

            int n;

            scanf("%d",&n);

            int p = 0;

            int q = 0;

            int c;

            while(n--)

            {

                int b;

                scanf("%d",&b);

                a[b]++;

                if(a[b]>=p)

                {

                    q=p;

                    p=a[b];

                    c=b;

                }

            }

            if (q==p)

                cout<<"Nobody"<<endl;

            else

                cout<< c <<endl;

        }

        return 0;

    }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: