您的位置:首页 > 其它

PAT (Advanced Level) Practise 1029 Median (25)

2017-07-21 00:52 316 查看


1029. Median (25)

时间限制

1000 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median
of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed
that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.
Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13


题意:给出两个序列,求着两个序列合并后的中位数

解题思路:可以直接当做输入了n+m个数,然后排一下序输出即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, m;
LL a[2000009];

int main()
{
while (~scanf("%d", &n))
{
for (int i = 1; i <= n; i++) scanf("%lld", &a[i]);
scanf("%d", &m);
for (int i = 1; i <= m; i++) scanf("%lld", &a[i + n]);
sort(a + 1, a + 1 + n + m);
printf("%lld\n", a[(n + m + 1) / 2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: