您的位置:首页 > 其它

PAT (Advanced Level) Practise 1025 PAT Ranking (25)

2017-07-21 00:09 323 查看


1025. PAT Ranking (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then
K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


题意:给出n组人的id和pat成绩,每个组有不同的人数,按最终所有人的排名输出,排名按分数来,相同分数的相同名次,相同名次的按id排,输出每个人的最终排名,所在组和所在组排名

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, k, sum;

struct node
{
int id, rank,sorce;
char ch[20];
friend bool operator <(node a, node b)
{
if (a.sorce != b.sorce) return a.sorce > b.sorce;
else return strcmp(a.ch,b.ch)<0;
}
}x[30009];

int main()
{
while (~scanf("%d",&n))
{
sum = 0;
for (int i = 1; i <= n; i++)
{
scanf("%d", &k);
for (int j = 0; j < k; j++) scanf("%s %d", &x[sum+j].ch, &x[sum+j].sorce),x[sum+j].id=i;
sort(x + sum, x + sum + k);
x[sum].rank = 1;
for (int j = 1; j < k; j++)
{
if (x[sum + j].sorce == x[sum - 1 + j].sorce) x[sum + j].rank = x[sum - 1 + j].rank;
else x[sum + j].rank = j + 1;
}
sum += k;
}
sort(x, x + sum);
int rank = 1;
printf("%d\n", sum);
printf("%s 1 %d %d\n", x[0].ch, x[0].id, x[0].rank);
for (int i = 1; i < sum; i++)
{
printf("%s ", x[i].ch);
if (x[i].sorce == x[i - 1].sorce) printf("%d", rank);
else { rank = i + 1; printf("%d", rank); }
printf(" %d %d\n", x[i].id, x[i].rank);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: