您的位置:首页 > 其它

PAT (Advanced Level) Practise 1024 Palindromic Number (25)

2017-07-21 00:01 537 查看


1024. Palindromic Number (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives
a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output
the number obtained at the Kth step and K instead.
Sample Input 1:
67 3

Sample Output 1:
484
2

Sample Input 2:
69 3

Sample Output 2:
1353
3


题意:给你一个数n,每次将它和它的翻转数相加,问这样操作几次后它会成为一个回文数

解题思路:数组模拟数的加法

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

char ch1[200],ch2[200],ans[200];
int step;

int add(char s[])
{
int len = strlen(s);
for (int i = 0; i < len; i++) ch2[i] = s[len - i - 1];
int x = 0;
for(int i=0;i<len;i++)
{
ans[i] = (s[i] - '0' + ch2[i] - '0' + x) % 10+'0';
x = (s[i] - '0' + ch2[i] - '0' + x) / 10;
}
if (x) ans[len++] = x + '0',ans[len]='\0';
else ans[len] = '\0';
int flag = 1;
for (int i = 0; i < len / 2; i++)
{
swap(ans[i], ans[len - 1 - i]);
if (ans[i] != ans[len - 1 - i]) flag = 0;
}
strcpy(ch1, ans);
return flag;
}

int main()
{
while (~scanf("%s %d", &ch1, &step))
{
int len = strlen(ch1),flag=1,cnt=0;
for (int i = 0; i < len / 2; i++)
if (ch1[i] != ch1[len - 1 - i]) flag = 0;
if (flag) { printf("%s\n0\n", ch1); continue; }
for (int i = 1; i <= step; i++)
{
cnt++;
if (add(ch1)) break;
}
printf("%s\n%d\n", ch1, cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: