您的位置:首页 > 其它

PAT (Advanced Level) Practise 1015 Reversible Primes (20)

2017-07-20 11:37 330 查看


1015. Reversible Primes (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.
Sample Input:
73 10
23 2
23 10
-2

Sample Output:
Yes
Yes
No


题意:给你一个数,将它转化为d进制后进行反转,然后再求出这个数为多少,若这个数和原数都为质数则输出Yes

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <map>

using namespace std;

const int INF=0x3f3f3f3f;
int a[1009];

int check(int x)
{
for(int i=2;i*i<=x;i++)
if(x%i==0) return 0;
return 1;
}

int mypow(int x,int y)
{
int sum=1;
for(int i=1;i<=y;i++)
sum*=x;
return sum;
}

int main()
{
int n,d;
while(~scanf("%d",&n)&&n>=0)
{
scanf("%d",&d);
if(check(n)==0||n==1) {printf("No\n");continue;}
int sum=0;
while(n)
{
a[sum++]=n%d;
n/=d;
}
int ans=0;
for(int i=0;i<=sum-1;i++)
{
int xx=a[i]*mypow(d,sum-1-i);
ans=ans+xx;
}
if(check(ans)&&ans!=1) printf("Yes\n");
else printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: