您的位置:首页 > 其它

HDU-1051Wooden Sticks (贪心)

2017-07-20 11:23 441 查看
Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) . 

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case,
and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 

 

Output

The output should contain the minimum setup time in minutes, one per line. 

 

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

Sample Output

2
1
3
贪心:把木头把l从大到小排序,l相同的w从大到小排序。然后记录第一个没有用到的木头。然后顺序找,再回过头来从没有用到的木头再顺序找,直到全部找完。
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <set>
#include <cmath>
#include <queue>
using namespace std;
const int maxn = 5005;
struct Node {
int l, w;
}node[maxn];
int visited[maxn];
bool cmp(const Node& n1, const Node& n2) {
return n1.l < n2.l || (n1.l == n2.l && n1.w < n2.w);
}
int main() {
//freopen("in.txt", "r", stdin);
int t;
cin >> t;
while (t--) {
int n;
cin >> n;
for (int i = 0; i < n; ++i) {
cin >> node[i].l >> node[i].w;
}
sort(node, node + n, cmp);
int ans = 0;
int start = 0, flag = 0;//start记录第一个没有用到的木头
memset(visited, 0, sizeof(visited));
while (start < n) {
ans++;
flag = 1;
for (int i = start + 1, j = start; i < n; ++i) {
if (visited[i])
continue;
if (node[i].l >= node[i].l && node[i].w >= node[j].w) {
j = i;
visited[i] = 1;
} else {
if (flag) {
start = i;
visited[i] = 1;
flag = 0;
}
}
}
//如果不存在没有用到的木头,就break
if (flag)
break;
}
cout << ans << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: