您的位置:首页 > 其它

Catch That Cow POJ - 3278

2017-07-20 11:02 344 查看
题目链接:点我

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?


Input

Line 1: Two space-separated integers: N and K


Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.


Sample Input

5 17


Sample Output

4


Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:

你每次可以达到当前点的左边或者右边或者当前点2倍坐标的位置,问是否能达到目标.


思路:

简单的bfs,同时标记你走过的位置就可以了.


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

struct ss
{
int x,step;
}q[100000+10];
bool vis[100000+10];
int n,k;

void bfs()
{
memset(vis,false,sizeof(vis));
int head=0;
int tail=0;
q[tail].x=n;
q[tail++].step=0;
vis
=true;
while(head<tail){
ss p=q[head++];
if(p.x==k){
cout<<p.step<<endl;
return ;
}
if(p.x-1>=0&&vis[p.x-1]==false){
q[tail].x=p.x-1;
q[tail++].step=p.step+1;
vis[p.x-1]=true;
} if(p.x+1<=100000&&vis[p.x+1]==false){
q[tail].x=p.x+1;
q[tail++].step=p.step+1;
vis[p.x+1]=true;
} if(p.x*2 <= 100000&&vis[p.x*2]==false){
q[tail].x=p.x*2;
q[tail++].step=p.step+1;
vis[p.x*2]=true;
}
}
}

int main()
{
while(scanf("%d %d",&n,&k)!=EOF){
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: