您的位置:首页 > 其它

hdu 2647 Reward(拓扑排序)

2017-07-20 10:14 429 查看

Reward

Problem Description

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)

then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output

For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1

1 2

2 2

1 2

2 1

Sample Output

1777

-1

思路:拓扑排序,

老套路,逆向建边,另开一个数组rank[i]记录点i最小比888大多少

然后判环,如过进队列的点不到n个,那么肯定存在环

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

const int maxn=10000+10;
const int maxv=20000+10;
struct edge
{
int v,next;
} E[maxv];
int first[maxn],vis[maxn],rak[maxn];
int n,m,len;

void solve()
{
memset(rak,0,sizeof(rak));
queue<int>q;
for(int i=1; i<=n; ++i)
if(!vis[i])
q.push(i);
while(!q.empty())
{
int u=q.front();
q.pop();
for(int i=first[u]; ~i; i=E[i].next)
{
int v=E[i].v;
rak[v]=max(rak[v],rak[u]+1);
--vis[v];
if(!vis[v])
q.push(v);
}
}
}

void add_edge(int u,int v)//邻接表存边
{
E[len].v=v,E[len].next=first[u],first[u]=len++;
}

int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(vis,0,sizeof(vis));
memset(first,-1,sizeof(first));
int u,v;
len=0;
for(int i=0; i<m; ++i)
{
scanf("%d%d",&u,&v);
add_edge(v,u);//逆向建边
++vis[u];
}
solve();
int ans=0,flag=0;
for(int i=1; i<=n; ++i)
{
if(vis[i])//判断是否存在没进队列的点
{
flag=1;
break;
}
ans+=rak[i];
}
if(flag)
printf("-1\n");
else
printf("%d\n",ans+888*n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: