您的位置:首页 > 其它

poj3249(记忆化搜索)Test for Job

2017-07-20 09:29 323 查看
Test for Job

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 11182 Accepted: 2641
Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will
compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A
city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 

The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 

The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000) 

The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)
Sample Input
6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output
7
//加源点,然后记忆化搜索
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int mn= 100000+10;
int inf;
struct node
{
int to,next;
} edge[1010000];
int n,m;
int head[mn];
int a[mn];
int in[mn],out[mn],d[mn];
int dfs(int i)
{
if(d[i]!=inf) return d[i];
if(head[i]==-1) return d[i]=a[i];
for(int j=head[i]; ~j; j=edge[j].next)
{
int u=edge[j].to;
if(d[i]<dfs(u)+a[i]) d[i]=d[u]+a[i];
}
return d[i];
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=1; i<=n; ++i)
scanf("%d",a+i);
memset(in,0,sizeof(in));
memset(head,-1,sizeof(head));
for(int i=0; i<m; ++i)
{
int u,v;
scanf("%d%d",&u,&v);
edge[i].to=v;
edge[i].next=head[u];
head[u]=i;
in[v]=1;
}
int tot=m,ans=0;
for(int i=1; i<=n; ++i)
if(!in[i])
{
edge[tot].to=i;
edge[tot].next=head[0];
head[0]=tot++;
}
memset(d,-0x3f3f3f3f,sizeof(d));
inf=d[0];
dfs(0);
printf("%d\n",d[0]);
}
return 0;
}

//拓扑排序+记忆化搜索
//拓扑感觉就是模拟了那个递归
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int mn= 100000+10;
struct node
{
int to,next;
} edge[1010000];
int n,m;
int head[mn];
int a[mn];
int in[mn],out[mn],d[mn],vis[mn];
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=1; i<=n; ++i)
scanf("%d",a+i);
memset(in,0,sizeof(in));
memset(out,0,sizeof(out));
memset(head,-1,sizeof(head));
for(int i=0; i<m; ++i)
{
int u,v;
scanf("%d%d",&u,&v);
edge[i].to=v;
edge[i].next=head[u];
head[u]=i;
in[v]++;
out[u]++;
}
memset(vis,0,sizeof(vis));
memset(d,-0x3f3f3f3f,sizeof(d));
int cnt=0;
for(int i=1; i<=n; ++i)
if(!in[i])
d[i]=a[i];
while(cnt<n)
{
for(int i=1; i<=n; i++)
if(!in[i]&&!vis[i])
{
for(int j=head[i]; ~j; j=edge[j].next)
{
int u=edge[j].to;
if(d[u]<d[i]+a[u]) d[u]=d[i]+a[u];
in[u]--;
}
vis[i]=1,cnt++;
}
}
int ans=INT_MIN;
for(int i=1; i<=n; ++i)
if(!out[i]) ans=max(ans,d[i]);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: