您的位置:首页 > 其它

POJ-1426 Find The Multiple(深搜)

2017-07-20 08:43 344 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32481 Accepted: 13581 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

题意:找出n的只含0和1的倍数m,答案可能有多个只输出其中一个就好。
这道题目是深搜,数学归纳法可得m小于20位在unsigned __int64 范围内,要用step记录递归的深度,只输出一个需要再找到一个是标记,只含0和1,从1开始进入深搜函数,每次*10或*10+1,都是只含0和1的,在判断一下是否是n的倍数就好。

代码:

#include<stdio.h>
int n;
int f;
//数学归纳法m小于19位在unsigned long long范围内
void dfs(unsigned long long m,int step)
{
if(step==19)//无符号长整型20位
return ;
if(f)//只输出一组,若不则会输出多组;
return;
if(m%n==0)//m是n的倍数
{
printf("%llu\n",m);
f=1;
return;
}
dfs(m*10,step+1);//只含0和1就是*10或*10+1;
dfs(m*10+1,step+1);
}
in
4000
t main()
{
while(scanf("%d",&n)&&n)
{
f=0;
dfs(1,0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: