您的位置:首页 > 其它

PAT (Advanced Level) Practise 1039 Course List for Student (25)

2017-07-19 11:43 501 查看


1039. Course List for Student (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the
courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student
names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing
order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0


题意:告诉你每门课有哪些学生,输出每个学生选了哪些课

解题思路:都放入vector即可,不过这题map会超时,需要自己写个hash

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

char ch[5];
int n,m,id,k;
vector<int>g[400009];

int get(char ch[])
{
return (ch[0]-'A')*10*26*26+(ch[1]-'A')*26*10+(ch[2]-'A')*10+ch[3]-'0';
}

int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<=40000;i++) g[i].clear();
for(int i=1;i<=m;i++)
{
scanf("%d%d",&id,&k);
for(int j=1;j<=k;j++)
{
scanf("%s",ch);
g[get(ch)].push_back(id);
}
}
for(int i=1;i<=n;i++)
{
scanf("%s",ch);
id=get(ch);
printf("%s %d",ch,g[id].size());
sort(g[id].begin(),g[id].end());
for(int j=0;j<g[id].size();j++) printf(" %d",g[id][j]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: