您的位置:首页

POJ 题目2506Tiling(大数)

2017-07-19 09:12 316 查看
Tiling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8128Accepted: 3941
Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?

Here is a sample tiling of a 2x17 rectangle.



Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14

公式a
=a[n-1]+a[n-2]*2

ac代码

#include<stdio.h>
#include<string.h>
int str[255][100];
void fun()
{
str[0][0]=1;
str[1][0]=1;
str[2][0]=3;
int temp,i,j;
temp=0;
for(i=3;i<=250;i++)
{
for(j=0;j<100;j++)
{
temp+=(str[i-2][j])*2+str[i-1][j];
str[i][j]=temp%10;
temp/=10;
}
}
}
int main()
{
fun();
int n;
while(scanf("%d",&n)!=EOF)
{
int i;
for(i=99;i>=0;i--)
{
if(str
[i]!=0)
break;
}
for(;i>=0;i--)
{
printf("%d",str
[i]);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: