您的位置:首页 > Web前端

【树状数组--思维】poj1990 MooFest

2017-07-18 18:40 435 查看
MooFest

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7910 Accepted: 3572
Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the
cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they
must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input
4
3 1
2 5
2 6
4 3

Sample Output
57

Source

USACO 2004 U S Open
[Submit]   [Go Back]   [Status]  
[Discuss]

题意:每头牛都有一个听力v,坐标x,保证各牛牛的坐标不同,若两头牛要交谈,则需要音量为:dis(i,j)*max(vi,vj);最后求任意两头牛需要交谈的音量的和;

思路:按照音量排序从小到大排序,那么没加入一头牛这头牛的音量就是最大的,和他交谈的话就要按它的音量来乘;每加入一个点,就要求出这个点与前面的点的距离;

开辟三个数组分别表示:比坐标x小的个数a、比x小的值b,这个点之前的总的位移量c;

那么这个点与之前各点的位移差为:a*x-b+(c-b)-x*(i-1-a)  (i表示当前是第几个点)

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=20005;

int N;
struct node
{
int v,x;
} A[maxn];
int C1[maxn],C2[maxn],C3[maxn];

int cmp(node a,node b)
{
if(a.v!=b.v)
return a.v<b.v;
return a.x<b.x;
}

int lowbit(int k)
{
return k&(-k);
}

void add(int x,int d,int *R)
{
while(x<maxn)
{
R[x]+=d;
x+=lowbit(x);
}
}

int sum(int x,int *R)
{
int ret=0;
while(x>0)
{
ret+=R[x];
x-=lowbit(x);
}
return ret;
}

int main()
{
while(~scanf("%d",&N))
{
memset( A,0,sizeof( A));
memset(C1,0,sizeof(C1));
memset(C2,0,sizeof(C2));
memset(C3,0,sizeof(C3));

for(int i=1; i<=N; i++)
scanf("%d%d",&A[i].v,&A[i].x);
sort(A+1,A+1+N,cmp); //先按照v升序,再按照x升序;

// for(int i=1;i<=N;i++)
// printf("%d %d\n",A[i].v,A[i].x);

ll ans=0;
for(int i=1; i<=N; i++)
{
ll csum=0;
int xx=A[i].x, vv=A[i].v;
int a = sum(xx,C1); //比坐标x小的坐标个数;
int b = sum(xx,C2); //比坐标x小的坐标和;
int c = sum(vv,C3); //小于v总的坐标和;
// printf("%d %d %d \n",a,b,c);
csum = a*xx-b+(c-b)-xx*(i-1-a);
ans+= csum*vv;
add(xx,1,C1);
add(xx,xx,C2);
add(vv,xx,C3);
// printf("%lld\n\n",csum*vv);
}

printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj