您的位置:首页 > 产品设计 > UI/UE

Number Sequence(规律)

2017-07-18 17:58 471 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 175342 Accepted Submission(s): 43324



Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5


/**************************************************************
Problem:
Language: C/C++
method:
date:2017 7
create by Songdan_Lee
n特别大,不能用数组一个一个求。寻找其循环周期。
****************************************************************/
#include<stdio.h>

int main(){
int a,b,n;
while(scanf("%d%d%d",&a,&b,&n)!=EOF){

if(a==0&&b==0&&n==0)
break;

int c[105]={0,1,1};

int i;
for( i=3;i<100;i++)
{
c[i]=(a*c[i-1]+b*c[i-2])%7;

if(c[i]==c[2]&&c[i-1]==c[1])//循环周期
break;

}
n=n%(i-2);//i-2为循环周期

if(n!=0)
printf("%d\n",c
);

else printf("%d\n",c[i-2]);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: