您的位置:首页 > 其它

HDU5933 +(双向队列)2016年中国大学生程序设计竞赛(杭州)

2017-07-18 15:13 489 查看


ArcSoft's Office Rearrangement

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1376    Accepted Submission(s): 491


Problem Description

ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.

There are N working
blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into K new
blocks by the following two operations:

- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.

- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.

Now the CEO wants to know the minimum operations to re-arrange current blocks into K block
with equal size, please help him.

 

Input

First line contains an integer T,
which indicates the number of test cases.

Every test case begins with one line which two integers N and K,
which is the number of old blocks and new blocks.

The second line contains N numbers a1, a2, ⋯, aN,
indicating the size of current blocks.

Limits
1≤T≤100
1≤N≤105
1≤K≤105
1≤ai≤105

 

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.

If the CEO can't re-arrange K new
blocks with equal size, y equals -1.

 

Sample Input

3
1 3
14
3 1
2 3 4
3 6
1 2 3

 

Sample Output

Case #1: -1
Case #2: 2
Case #3: 3

 

Source

2016年中国大学生程序设计竞赛(杭州)

题解   给你n个位置,让你经过合并和分开步骤,变成k个位置+

合并 只能相邻合并,合并后的位置等于两个之和;

分开  任意分开,分开的位置相加等于原来的位置

思路

对于  sum/k,不能整除的,输出-1;

可以整除的

如果小于sum/k;,这合并;

如果等于sum/k,这不操作

如果大于sum/,这分开

双向队列 http://blog.csdn.net/hyyjiushiliangxing/article/details/51909249

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
long long  a[100005];
int main()
{
deque<long long>q;//双向队列
int t,T;
long long n,k,m,mm;
long long sum,ans;
T=1;
scanf("%d",&t);
while(t--)
{
scanf("%lld%lld",&n,&k);
sum=0;
ans=0;
while(!q.empty())
{
q.pop_front();
}
for(int i=0; i<n; i++)
{
scanf("%lld",&a[i]);
sum+=a[i];
q.push_back(a[i]);
}
if(sum%k!=0)
{
printf("Case #%d: -1\n",T++);
}
else
{
m=sum/k;
while(!q.empty())
{
mm=q.front();
q.pop_front();
if(mm>m)
{

ans+=mm/m;
mm=mm%m;
if(mm%m==0)
ans--;
}
else if(mm==m)
continue;
if(mm==0)
continue;
if(mm<m)
{
sum=mm;
while(!q.empty())
{
mm=q.front();
q.pop_front();
sum+=mm;
ans++;
if(sum==m)
{
break;
}
if(sum>m)
{
q.push_front(sum);
break;
}
}
}
}
printf("Case #%d: %lld\n",T++,ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
相关文章推荐