您的位置:首页 > 其它

【HDU 2844】Coins(多重背包)

2017-07-18 15:04 357 查看
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without
change) and he known the price would not more than m.But he didn't know the exact price of the watch. 

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

InputThe input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test
case is followed by two zeros.
OutputFor each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0


Sample Output
8
4


/*
多重背包问题:直接背包显然超时,使用空间换时间
开一个cnt数组保存已使用的数目,之和像普通背包一样做就好
*/

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
const int MXN = 105, MXM = 1e5 + 5;
int n, m, a[MXN], c[MXN], dp[MXM], cnt[MXM];
int main()
{
while(scanf("%d%d", &n, &m) != EOF && (n != 0 || m != 0))
{
for(int i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
}
for(int i = 1; i <= n; i++)
{
scanf("%d", &c[i]);
}
memset(dp, 0, sizeof(dp));
dp[0] = 1;
int ans = 0;
for(int i = 1; i <= n; i++)
{
memset(cnt, 0, sizeof(cnt));
for(int j = a[i]; j <= m; j++)
{
if(!dp[j] && dp[j - a[i]] && cnt[j - a[i]] < c[i])
{
dp[j] = 1;
ans++;
cnt[j] = cnt[j - a[i]] + 1;
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: