您的位置:首页 > 其它

HDU4704:Sum(费马小定理 & 隔板法)

2017-07-17 20:31 197 查看


Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 2767    Accepted Submission(s): 1155


Problem Description



 

Sample Input

2

 

Sample Output

2
Hint
1. For N = 2, S(1) = S(2) = 1.

2. The input file consists of multiple test cases.

 

Source

2013 Multi-University Training Contest 10
思路:S(K)相当于把N分成K部分的种数,就是C(N-1, K-1),S(1)+...+S(N)就是2^(N-1),由于N很大不能直接快速幂,根据费马小定理a^(p-1)=1modp,将N-1分成若干个p-1+余数k,就是2^k%mod就搞定了。

# include <iostream>
# include <cstdio>
# include <cstring>
typedef long long LL;
const int maxn = 1e5+10;
const LL mod = 1e9+7;
char s[maxn];
LL cal()
{
LL ans = 0;
for(int i=0; s[i]; ++i)
ans = (ans*10+s[i]-'0')%(mod-1);
return ans;
}

LL qmod(LL a, LL b)
{
LL ans=1, pow=a;
for(;b;b>>=1)
{
if(b&1) ans = ans*pow%mod;
pow = pow*pow%mod;
}
return ans;
}
int main()
{
while(~scanf("%s",s))
{
LL pow = (cal()+mod-2)%(mod-1);
printf("%lld\n",qmod(2,pow));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: