您的位置:首页 > 其它

【二分】hdu 1969 Pie(同木材加工)

2017-07-17 15:37 357 查看

Pie

[align=center]Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12488    Accepted Submission(s): 4420
[/align]

[align=left]Problem Description[/align]

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them
gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

 

[align=left]Input[/align]

One line with a positive integer: the number of test cases. Then for each test case:

---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

 

[align=left]Output[/align]

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute
error of at most 10^(-3).
 

[align=left]Sample Input[/align]

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

 

[align=left]Sample Output[/align]

25.1327
3.1416
50.2655

 

///AC代码
#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
double r[11000];
double s[11000];
const double p = acos(-1.0); //大家注意一下这里啊 派千万别取3.1415926 一定要这么取 我
//因为这个wa了无数次

int main()
{
int num;
cin >> num;
int n;
double f;
for (int i = 0; i < num; i++)
{
double ts = 0;
cin >> n >> f;
f++;

for (int j = 0; j < n; j++)
{
cin >> r[j];
s[j] = p * r[j] * r[j];
ts += s[j];
}

double left = 0, right = ts / f;
double mid;

while (right - left > 1e-7)
{
mid = (left + right) * 0.5;
int sum = 0;
for (int j = 0; j < n; j++)
{
sum += int(s[j] / mid);
}
if (sum >= f)
{
left = mid;
}
else
{
right = mid;
}
}
cout << fixed << setprecision(4) << mid << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法 hdu