您的位置:首页 > 其它

poj 1182 食物链 (带权并查集升级版)

2017-07-16 20:52 453 查看
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 

现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。

有人用两种说法对这N个动物所构成的食物链关系进行描述: 

第一种说法是"1 X Y",表示X和Y是同类。 

第二种说法是"2 X Y",表示X吃Y。 

此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 

1) 当前的话与前面的某些真的话冲突,就是假话; 

2) 当前的话中X或Y比N大,就是假话; 

3) 当前的话表示X吃X,就是假话。 

你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

Input
第一行是两个整数N和K,以一个空格分隔。 

以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 

若D=1,则表示X和Y是同类。 

若D=2,则表示X吃Y。

Output
只有一个整数,表示假话的数目。

Sample Input
100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5


Sample Output
3

题解报告

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<cmath>
//#include <bits/stdc++.h>
using namespace std;
const int N = 5e5+7;
typedef long long LL;
LL a
;
int n, k;
struct node
{
int parent,relation;
}p
;
void init()
{
for(int i=0;i<=n;i++)
{
p[i].parent=i,p[i].relation=0;
}
return ;
}

int f(int x)
{
if(p[x].parent==x) return x;
else
{
int t=p[x].parent;
p[x].parent=f(p[x].parent);
p[x].relation=(p[x].relation+p[t].relation)%3;
return p[x].parent;
}
}

int main()
{

scanf("%d %d", &n, &k);

init();
int sum=0;
while(k--)
{
int d, x, y;
scanf("%d %d %d", &d, &x, &y);
if(x>n||y>n)   sum++;
else if(d==2)
{
if(x==y) sum++;
else
{
int a=f(x),b=f(y);
if(a!=b)
{
p[b].parent=a;
p[b].relation=(d-1+3-p[y].relation+p[x].relation)%3;
}
else if((3-p[x].relation+p[y].relation)%3!=1) sum++;
}
}
else
{
int a=f(x),b=f(y);
if(a!=b)
{
p[b].parent=a;
p[b].relation=(d-1+3-p[y].relation+p[x].relation)%3;
}
else if(p[x].relation!=p[y].relation) sum++;
}

}
cout<<sum<<endl;

return 0;
}


种类并查集

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<cmath>
//#include <bits/stdc++.h>
using namespace std;
const int N = 200000+7;
typedef long long LL;
int vis
, f
, c
;
LL size1
, col
;
vector<int>p
;
LL cnt;
int get(int x)
{
if(x==f[x]) return x;
return f[x]=get(f[x]);
}
void marge(int x,int y)
{
int a=get(x),b=get(y);
f[b]=a;
return ;
}

int main()
{
int n, k;
scanf("%d %d", &n, &k);
for(int i=1; i<=n*3+10; i++) f[i]=i;
int cnt=0;
for(int i=0; i<k; i++)
{
int x, y, z;
scanf("%d %d %d", &z, &x, &y);
if(x>n||y>n||x<1||y<1)
{
cnt++;
continue;
}
if(z==1)
{
if(get(x)==get(y+n)||get(x)==get(y+2*n)) cnt++;
else
{
marge(x,y);
marge(x+n,y+n);
marge(x+2*n,y+2*n);
}
}
else
{
if(x==y) cnt++;
else
{
if(get(x)==get(y)||get(x)==get(y+2*n)) cnt++;
else
{
marge(x,y+n);
marge(x+n,y+2*n);
marge(x+2*n,y);
}
}
}
}
cout<< cnt <<endl;
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: