您的位置:首页 > 其它

Connections in Galaxy War ZOJ - 3261

2017-07-16 19:42 519 查看
In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many
problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was
connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And
therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more th
4000
an 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0, p1, ... , pn-1(0 <= pi <=
1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integersa, b (0
<= a, b <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star bwas available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

<b< dd="">

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

<b< dd="">

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

<b< dd="">

Sample Output

1
-1
-1
-1


题意挺明确的,就不复述了。

这题考察的是并查集,不过思路要翻一下,其实就是逆向的数据处理,从后往前处理每个q,有destroy就add,

这样就变成的正常的并查集了。

上代码:

#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
#include<iostream>
#include<map>
using namespace std;
struct node
{
char a[10];
int x;
int y;
};
stack<int> out; //用于输出
node op[20001];
node qq[50001];
int f[10001];
int n,m,q;
int p[10001];
map<int ,bool> pan; // 用hash的方法判重
int getf(int x)
{
if(f[x]==x)return f[x];
f[x] = getf(f[x]);
return f[x];
}
void add(int x,int y)
{
int tx = getf(x);
int ty = getf(y);
if(tx==ty){f[ty]=tx;return;}
if(p[tx] > p[ty])
{
f[ty] = tx;
}
else if(p[tx] < p[ty])
{
f[tx] = ty;
}
else if(p[tx] == p[ty])
{
if(ty < tx)
{
f[tx] = ty;
}
else if(ty > tx)
{
f[ty] = tx;
}
}
return ;
} // 以上是并查集的处理
int w = 1;
int main()
{
while(scanf("%d", &n)!=EOF)
{
if(!w)printf("\n");
w = 0;
for(int i=0; i<n; i++){scanf("%d",&p[i]); f[i]=i;}
scanf("%d", &m);
for(int i=0; i<m; i++)
{
scanf("%d %d",&op[i].x,&op[i].y); // x 小
if(op[i].x > op[i].y)swap(op[i].x,op[i].y); // 方便hash
}
scanf("%d",&q);
for(int i=0; i<q; i++)
{
scanf(" %s", qq[i].a);
if(qq[i].a[0] == 'd')
{
scanf("%d %d",&qq[i].x,&qq[i].y);
if(qq[i].x > qq[i].y) swap(qq[i].x,qq[i].y);
pan[qq[i].x*10000+qq[i].y] = 1;
}else scanf("%d",&qq[i].x);
}
for(int i=0; i<m; i++)
{
if(pan[op[i].x*10000+op[i].y]==0)
add(op[i].x,op[i].y);
}
for(int i=q-1; i>=0; --i)
{
if(qq[i].a[0] == 'd')
{
add(qq[i].x,qq[i].y);
pan[qq[i].x*10000+qq[i].y] = 0; // 这里是为了下组数据重复利用map
}
else
{
int tmp = getf(qq[i].x);
if(p[tmp] > p[qq[i].x])
{
out.push(tmp);
}
else out.push(-1);
}
}
while(!out.empty())
{
printf("%d\n",out.top()); out.pop();
}
}
return 0;
}

水波。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集 思维逆向