您的位置:首页 > 其它

PAT (Advanced Level) Practise 1053 Path of Equal Weight (30)

2017-07-16 10:14 405 查看


1053. Path of Equal Weight (30)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes
along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower
number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains
N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]


where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of
the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2,
..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


题意:给你一个以0为根节点的树,统计并输出根节点到叶子节点和为m的路径

解题思路:dfs保存路径即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n,m,ss,u,k,v;
int s[105],nt[200],e[200],w[105];
int res,b[200];

struct node
{
int x[200];
friend bool operator <(node a,node b)
{
for(int i=1;;i++)
if(a.x[i]!=b.x[i]) return w[a.x[i]]>w[b.x[i]];
}
}ans[200];

void dfs(int k,int step,int sum)
{
b[step]=k;
if(s[k]==-1&&sum==ss)
{
ans[res].x[0]=step;
for(int i=1;i<=step;i++)
ans[res].x[i]=b[i];
res++;
}
for(int i=s[k];~i;i=nt[i])
dfs(e[i],step+1,sum+w[e[i]]);
}

int main()
{
while(~scanf("%d%d%d",&n,&m,&ss))
{
memset(s,-1,sizeof s);
int cnt=0;
for(int i=0;i<n;i++) scanf("%d",&w[i]);
for(int i=0;i<m;i++)
{
scanf("%d%d",&u,&k);
for(int j=0;j<k;j++)
{
scanf("%d",&v);
nt[cnt]=s[u],s[u]=cnt,e[cnt++]=v;
}
}
res=0;
dfs(0,1,w[0]);
sort(ans,ans+res);
for(int i=0;i<res;i++)
{
printf("%d",w[ans[i].x[1]]);
for(int j=2;j<=ans[i].x[0];j++)
printf(" %d",w[ans[i].x[j]]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: