您的位置:首页 > 产品设计 > UI/UE

PAT (Advanced Level) Practise 1051 Pop Sequence (25)

2017-07-16 10:00 417 查看


1051. Pop Sequence (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain
1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow,
each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO


题意:给你n个数,让你按1~n的顺序压入栈,栈的大小为m,问能不能使得弹出顺序为给出的序列

解题思路:用stack模拟即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, m, q;
int a[1009];

int main()
{
while (~scanf("%d%d%d", &m, &n, &q))
{
while (q--)
{
for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
stack<int>s;
int cnt = 1;
for (int i = 1; i <= n; i++)
{
s.push(i);
if (s.size() > m) break;
while (!s.empty() && s.top() == a[cnt]) s.pop(), cnt++;
}
if (s.empty()) printf("YES\n");
else printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: