您的位置:首页 > 其它

【STL】hdu 4585 Shaolin

2017-07-15 15:29 453 查看

Shaolin

[align=center]Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3162    Accepted Submission(s): 1339
[/align]

[align=left]Problem Description[/align]

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding
the Buddism scripture, but fighting skill is also taken into account.

When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose
fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.

The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

 

[align=left]Input[/align]

There are several test cases.

In each test case:

The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)

The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.

The input ends with n = 0.

 

[align=left]Output[/align]

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new
monk's id first ,then the old monk's id.
 

[align=left]Sample Input[/align]

3
2 1
3 3
4 2
0

 

[align=left]Sample Output[/align]

2 1
3 2
4 2

 

///AC代码
#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

/*map<int, int> p;
map<int, int>:: iterator iter;
int main()
{
int n;
while (scanf("%d", &n) && n)
{
p.clear();
p[1000000000] = 1;
int id, x, s1, s2;
for (int k = 0; k < n; k++)
{
cin >> id >> x;
p[x] = id;
for (int i = x - 1; i > 0; i--)
{
if (p[i] != 0)
{
s1 = p[i];
break;
}
}
for (int j = x + 1; j < 1000000005; j++)
{
if (p[j] != 0)
{
s2 = p[j];
break;
}
}
if (x - s1 <= s2 - x)
{
cout << p[x] << " " << s1 << endl;
}
else if (x - s1 > s2 - x)
{
cout << p[x] << " " << s2 << endl;
}
}
}
return 0;
}*/

int main()
{
int i, n, id, f;
while (~scanf("%d", &n), n)
{
map<int, int> a;
a.clear();
a[1000000000] = 1;
for (i = 0; i < n; i++)
{
scanf("%d%d", &id, &f);
printf("%d ", id);
map<int, int>::iterator it = a.lower_bound(f);
if (it == a.end())
{
printf("%d\n", it->second);
}
else
{
int t1 = it->first; ///战斗力
int t2 = it->second;///id
if (it != a.begin())
{
it--;
if (f - it->first <= t1 - f)
{
printf("%d\n", it->second);
}
else
{
printf("%d\n", t2);
}
}
else
{
printf("%d\n", t2);
}
}
a[f] = id;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  stl 算法 hdu