您的位置:首页 > 其它

HDU 2509 Be the Winner (尼姆博弈)

2017-07-14 20:33 393 查看


Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3692    Accepted Submission(s): 2062


Problem Description

Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.

For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 

the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

 

Input

You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

 

Output

If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

 

Sample Input

2
2 2
1
3

 

Sample Output

No
Yes

 

Source

ECJTU 2008 Autumn Contest

题意:

其他与尼姆博弈相同,但它不能取则输。

POINT:

分单堆和多堆讨论。若没有多堆,则看单堆数量奇偶。若有多堆,异或为0则后手赢,反之先手赢。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
#define ll long long

int main()
{
int n;
while(~scanf("%d",&n))
{
int res=0;

int t=0;
while(n--)
{
int a;
scanf("%d",&a);
if(a!=1) t++;
res=res^a;
}
if(res==0&&t==0) printf("Yes\n");//T0态 无多堆,单堆是偶
else if(res==1&&t==0) printf("No\n");//S0态 无多堆,单堆是奇
else if(res!=0) printf("Yes\n");//S2 S1 //有多堆,异或非0
else printf("No\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: