您的位置:首页 > 其它

PAT (Advanced Level) Practise 1068 Find More Coins (30)

2017-07-14 15:38 537 查看


1068. Find More Coins (30)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each
bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for
it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=104, the total number of coins) and M(<=102, the amount of money Eva has to pay). The second
line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1 <= V2 <= ... <= Vk such that V1 + V2 +
... + Vk = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution"
instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].
Sample Input 1:
8 9
5 9 8 7 2 3 4 1

Sample Output 1:
1 3 5

Sample Input 2:
4 8
7 2 4 3

Sample Output 2:
No Solution


题意:给你n个硬币,问用它们能不能组成m的价值,若能,输出最小的序列

解题思路:暴力dfs,先将所有硬币从小到大进行排序,求出后缀即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, m;
int a[10009],sum[10009];
vector<int>g;

int dfs(int k, int sum1)
{
if (sum1 == m) return 1;
if (sum1 > m || k > n || sum1 + sum[k] < m) return 0;
if (dfs(k + 1, sum1 + a[k]))
{
g.push_back(a[k]);
return 1;
}
return dfs(k + 1, sum1);
}

int main()
{
while (~scanf("%d%d", &n, &m))
{
g.clear();
for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
sort(a + 1, a + 1 + n);
sum[n + 1] = 0;
for (int i = n; i >= 1; i--) sum[i] = sum[i + 1] + a[i];
if (!dfs(1, 0)) { printf("No Solution\n"); continue; }
else
{
sort(g.begin(), g.end());
printf("%d", g[0]);
int Size = g.size();
for (int i = 1; i < Size; i++) printf(" %d", g[i]);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: