您的位置:首页 > 其它

博客园首页新随笔联系管理订阅 随笔- 524 文章- 0 评论- 20 hdu-5810 Balls and Boxes(概率期望)

2017-07-14 13:20 656 查看

Balls and Boxes

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 798 Accepted Submission(s): 527


[align=left]Problem Description[/align]
Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as

V=∑mi=1(Xi−X¯)2m

where Xi is the number of balls in the ith box, and X¯ is the average number of balls in a box.
Your task is to find out the expected value of V.

[align=left]Input[/align]
The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.
The input is terminated by n = m = 0.

[align=left]Output[/align]
For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.

[align=left]Sample Input[/align]

2 1

2 2

0 0

[align=left]Sample Output[/align]

0/1

1/2

Hint

In the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.

[align=left]Author[/align]
SYSU

[align=left]Source[/align]
2016 Multi-University Training Contest 7
题解:
转自:http://blog.csdn.net/qq978874169/article/details/52165136



#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
typedef long long int ll;
ll n,m;
ll fenzi,fenmu;
ll tmp;
ll gcd(ll a,ll b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
while(~scanf("%lld%lld",&n,&m)&&(n*m))
{
fenzi=n*(m-1);
fenmu=m*m;
tmp=gcd(fenzi,fenmu);
fenzi/=tmp;
fenmu/=tmp;
printf("%lld/%lld\n",fenzi,fenmu);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐