您的位置:首页 > 其它

POJ 1163 The Triangle(入门动规)

2017-07-14 11:05 573 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 49860Accepted: 30112
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to
the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle
is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Source

IOI 1994

状态转移方程:dp[i][j]=max(dp[i][j],max(dp[i-1][j-1],dp[i-1][j])+f[i][j]);

dp[i][j]表示在第i行第j列可以到达的最大值。

AC代码

#include<iostream>
#include<cstdio>
using namespace std;
int f[105][105];
int dp[105][105];
int main(){
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++){
for(int j=1;j<=i;j++){
scanf("%d",&f[i][j]);
}
}
for(int i=1;i<=n;i++){
for(int j=1;j<=i;j++){
if(dp[i][j]==0)dp[i][j]=f[i][j];
dp[i][j]=max(dp[i][j],max(dp[i-1][j-1],dp[i-1][j])+f[i][j]);
}
}
int ans=0;
for(int i=1;i<=n;i++){
ans=max(ans,dp
[i]);
}
printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 动态规划