您的位置:首页 > 编程语言 > Java开发

N!的位数 【java 高精度处理】

2017-07-12 19:11 141 查看
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1

2

3

Sample Output

1

2

6

import java.util.*;
import java.math.*;

class Main {
public static void main(String[] args){
Scanner cin = new Scanner (System.in);
while(cin.hasNext()){
int n;
n=cin.nextInt();
BigInteger sum=BigInteger.ONE;
for(int  i = 1 ; i <= n ;i++ ){
BigInteger a=BigInteger.valueOf(i);
sum=sum.multiply(a);
}
System.out.println(sum);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: