您的位置:首页 > 其它

HDU 1505 City Game (单调栈+最大子矩阵面积)

2017-07-12 18:16 381 查看


City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7184    Accepted Submission(s): 3120


Problem Description

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied.
The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in
each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied
units are marked with the symbol F.

 

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated
by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

 

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

 

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

 

Sample Output

45
0

 

Source

Southeastern Europe 2004

题意:

找出F组成的最大子矩形面积。

point:

0 0 0 1             0 0 0 1

1 1 1 1    变为 1 2 3 4    即在它左边有几个连续的1. 1即‘F’。

1 1 0 1             1 2 0 1

法1:之后在利用单调栈寻找最大矩阵,一列一列找,区间长度*(区间内最小值)。 o(n)

法2:常规最大子矩阵面积做法,找出上界和下界    也是 o(n)方法。

法1:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stack>
#define  ll long long
const int N = 1112;
const int inf=0x3f3f3f3f;
using namespace std;
int ans;
int a

;
int n,m;
void f()
{
stack<int> q;
int ha
;
for(int j=1;j<=m;j++)
{
for(int i=1;i<=n;i++)
{
ha[i]=i;
}
for(int i=1;i<=n;i++)
{

if(a[i][j]==0)
{
while(!q.empty())
{
ans=max(ans,(i-ha[q.top()])*a[q.top()][j]);
q.pop();
}
continue;
}
while(!q.empty()&&a[i][j]<a[q.top()][j])
{
ha[i]=q.top();
ans=max(ans,(i-ha[q.top()])*a[q.top()][j]);
q.pop();
}
q.push(i);
}
while(!q.empty())
{
ans=max(ans,(n+1-ha[q.top()])*a[q.top()][j]);
q.pop();
}
}
}
int main()
{
int T;
scanf("%d
ed75
",&T);
while(T--)
{
ans=0;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
int now=0;
for(int j=1;j<=m;j++)
{
char c;
cin>>c;
if(c=='F') now++;
else now=0;
a[i][j]=now;
}
}
f();
printf("%d\n",3*ans);
}
}


法2:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stack>
#define  ll long long
const int N = 1112;
const int inf=0x3f3f3f3f;
using namespace std;
int ans;
int a

;
int n,m;
void f()
{
int up
,down
;
for(int j=1;j<=m;j++)
{
for(int i=1;i<=n;i++)
{
up[i]=i;
while(up[i]-1>=1&&a[up[i]-1][j]>=a[i][j])
up[i]=up[up[i]-1];
}
for(int i=n;i>=1;i--)
{
down[i]=i;
while(down[i]+1<=n&&a[down[i]+1][j]>=a[i][j])
down[i]=down[down[i]+1];
}
for(int i=1;i<=n;i++)
{
ans=max(ans,(down[i]-up[i]+1)*a[i][j]);
}

}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
ans=0;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
int now=0;
for(int j=1;j<=m;j++)
{
char c;
cin>>c;
if(c=='F') now++;
else now=0;
a[i][j]=now;
}
}
f();
printf("%d\n",3*ans);
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: