您的位置:首页 > 其它

POJ--1002--487-3279

2017-07-12 10:06 441 查看
Description
Businesses like to have memorable telephone numbers. Oneway to make a telephone number memorable is to have it spell a memorable wordor phrase. For example, you can call the University of Waterloo by dialing thememorable TUT-GLOP. Sometimes
only part of the number is used to spell a word.When you get back to your hotel tonight you can order a pizza from Gino's bydialing 310-GINO. Another way to make a telephone number memorable is to groupthe digits in a memorable way. You could order your pizza
from Pizza Hut bycalling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphenbetween the third and fourth digits (e.g. 888-1200). The keypad of a phonesupplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 

D, E, and F map to 3 

G, H, and I map to 4 

J, K, and L map to 5 

M, N, and O map to 6 

P, R, and S map to 7 

T, U, and V map to 8 

W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added andremoved as necessary. The standard form of TUT-GLOP is 888-4567, the standardform of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (Theydial the same number.) 

Your company is compiling a directory of telephone numbers from localbusinesses. As part of the quality control process you want to check that notwo (or more) businesses in the directory have the same telephone number. 
Input
The input willconsist of one case. The first line of the input specifies the number oftelephone numbers in the directory (up to 100,000) as a positive integer aloneon the line. The remaining lines list the telephone numbers in the directory,with
each number alone on a line. Each telephone number consists of a stringcomposed of decimal digits, uppercase letters (excluding Q and Z) and hyphens.Exactly seven of the characters in the string will be digits or letters. 
Output
Generate a line ofoutput for each telephone number that appears more than once in any form. Theline should give the telephone number in standard form, followed by a space,followed by the number of times the telephone number appears in the directory.Arrange
the output lines by telephone number in ascending lexicographicalorder. If there are no duplicates in the input print the line: 

No duplicates. 
Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279
Sample Output
310-1010 2
487-3279 4
888-4567 3
 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include&l
6a91
t;map>
#include<algorithm>
#include<iostream>
#include<string>
using namespace std;
int main()
{
map<char,char> mp;
mp['0']='0';
mp['1']='1';
mp['A']=mp['B']=mp['C']=mp['2']='2';
mp['D']=mp['E']=mp['F']=mp['3']='3';
mp['G']=mp['H']=mp['I']=mp['4']='4';
mp['J']=mp['K']=mp['L']=mp['5']='5';
mp['M']=mp['N']=mp['O']=mp['6']='6';
mp['P']=mp['R']=mp['S']=mp['7']='7';
mp['T']=mp['U']=mp['V']=mp['8']='8';
mp['W']=mp['X']=mp['Y']=mp['9']='9';
map<string,int> mmp;
int t,k,i;
cin>>t;
char a[1005];
while(t--)
{
scanf("%s",a);
string b;
k=0;
for(i=0;a[i];i++)
{
if(a[i]!='-')
{
b+=mp[a[i]];
k++;
}
if(k==3)
{
b+='-';
k=4;
}
}
if(mmp.find(b)!=mmp.end())
{
mmp[b]++;
}
else
{
mmp[b]=1;
}
}
int r=0;
map<string,int>::iterator it;
for(it=mmp.begin();it!=mmp.end();it++)
{
if((it->second)>=2)
{
cout<<it->first<<' '<<it->second<<endl;
r=1;
}
}
if(r==0)
printf("No duplicates.\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: