您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集统计求不同集合个数)

2017-07-11 15:19 369 查看


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31224    Accepted Submission(s): 15516


Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

 

Author

Ignatius.L

 

Source

杭电ACM省赛集训队选拔赛之热身赛

 

Recommend

Eddy

题意:给n个点,m个关系,统计共有多少个不同集合

也是并查集的常用用法,直接合并有关系的集合,也是取最小的pre

#include <iostream>

#include <cstring>

#include <cstdio>

#include <cmath>

#include <algorithm>

#define maxn 1010

using namespace std;

int pre[maxn];

int off[maxn];

int fr(int x)

{

    int r=x;

    while(r!=pre[r])r=pre[r];

    int j=x;

    while(x!=r)

    {

        j=pre[x];

        pre[x]=j;

        x=j;

    }

    return r;

}

void join(int x,int y)

{

    int r1=fr(x);

    int r2=fr(y);

    if(r1>r2)pre[r1]=r2;

    else if(r1<r2)pre[r2]=r1;

}

int main()

{

    int t;

    scanf("%d",&t);

    int a,b,m,n;

    int mark[maxn];

    while(t--)

    {

        scanf("%d%d",&n,&m);

        memset(mark,0,sizeof(mark));

        for(int i=1;i<=n;i++)pre[i]=i;

        for(int i=0;i<m;i++)

        {

            scanf("%d%d",&a,&b);

            join(a,b);

        }

        int ans=0;

        for(int i=1;i<=n;i++)

        {

            int r=fr(i);

            if(!mark[r]){ans++;mark[r]=1;}

        }

        printf("%d\n",ans);

    }

    return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: