您的位置:首页 > 其它

hdu 1260 Tickets(DP)

2017-07-11 07:53 337 查看

Tickets

Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.

A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.

Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

1) An integer K(1<=K<=2000) representing the total number of people;

2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;

3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input

2

2

20 25

40

1

8

Sample Output

08:00:40 am

08:00:08 am

思路:每一个人可以自己买,也可以和前面的或后面的人一起买,

也就相当于,对这个人来说有两种选择,自己买,或者和前面的人一起买

状态转移方程:dp[i]=min(dp[i-1]+s1[i],dp[i-2]+s2[i]);

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn=2000+10;
int s1[maxn],s2[maxn];
int dp[maxn];

int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; ++i)
scanf("%d",&s1[i]);
for(int i=2; i<=n; ++i)
scanf("%d",&s2[i]);
dp[1]=s1[1];
for(int i=2; i<=n; ++i)
dp[i]=min(dp[i-1]+s1[i],dp[i-2]+s2[i]);
int time=(dp
/3600+8)%24;
int minute=(dp
/60)%60;
int second=dp
%60;
if(time>12)
printf("%02d:%02d:%02d pm\n",time%12,minute,second);
else
printf("%02d:%02d:%02d am\n",time,minute,second);
}
return 0;
}


ps:DP主要是抽象问题的思想,把状态转移方程求出来,其他的就很好写了
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: