您的位置:首页 > 其它

hdu 1358 Period(KMP之next数组)

2017-07-10 10:58 330 查看

Period

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

这道题考察的是KMP算法中next数组的应用,必须理解透next[]数组代表的含义才能通过它解决这道题。

  思路是先构造出 next[] 数组,下标为 i,定义一个变量 j = i - next[i] 就是next数组下标和下标对应值的差,如果这个差能整除下标 i,即 i%j==0 ,则说明下标i之前的字符串(周期性字符串长度为 i)一定可以由一个前缀周期性的表示出来,这个前缀的长度为刚才求得的那个差,即 j,则这个前缀出现的次数为 i/j 。所以最后输出i和i/j即可。

举这道题的第二组输入样例为例:

  其next[]数组为:

i      0  1  2  3  4  5  6  7  8  9  10 11 12
a[i]    a  a  b  a  a  b  a  a  b  a  a  b
next[i] -1  0  1  0  1  2  3  4  5  6  7  8  9




next[i]值是0或-1的忽略。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn=1000000+10;
char str[maxn];
int nxt[maxn];
int n;

void get_next()
{
for(int q=0,i=1;i<n;++i)
{
while(q&&str[q]!=str[i])
q=nxt[q];
if(str[q]==str[i])
++q;
nxt[i+1]=q;
}
}

int main()
{
int t=0;
while(~scanf("%d",&n),n)
{
scanf("%s",str);
get_next();
printf("Test case #%d\n",++t);
for(int i=1;i<=n;++i)
{
if(!nxt[i])
continue;
int k=i-nxt[i];
if(i%k==0)
printf("%d %d\n",i,i/k);
}
}
return 0;
}


参考博客:

呓语
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: