您的位置:首页 > 其它

HDU 1045 Fire Net 详细题解(二分图经典模型)

2017-07-08 23:28 393 查看


Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12117    Accepted Submission(s): 7306


Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least
one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses
in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The
next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

 

Sample Output

5
1
5
2
4

 

Source

Zhejiang University Local Contest 2001

 

题目描述:对一个给定的n*n的地图,放入炮塔,使得它们之间不冲突。当它们在同一行或同一列时且中间没有障碍物,冲突。求最多能放入多少炮塔。

二分图匹配经典模型。 

对每一行的联通块缩点放入x集合,每一列的联通块缩点放入y集合。若联通块之间有交点,连边。之后做一次最大匹配就可以求解。

二分图好奇妙~这题会发现, 一行跟一列只能有一个炮台, 那么一行中各列是互斥的,一列中各行是互斥的。。根据二分图匹配的性质,两边的点只能连一个,这样也是互斥的, 换句话说,你选了其中一行(左面的点),就只能选这一行中的某一列(右面的点),这样就达到了“ 一行跟一列只能有一个炮台”~然后就是题解说吧, 把每行连通的变成一个点,同理每列,每个行联通块里最多一个列联通块,他们之间做二分图就是题目所求了~如果一个行联通块与一个列联通块想交,就连边~
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 1e3;
char maze[maxn][maxn];
int idx[maxn][maxn], idy[maxn][maxn], ans, book[maxn], match[maxn], n;
vector<int> v[maxn];
int Find(int x)
{
for(int i = 0; i < v[x].size(); i++)
{
int to = v[x][i];
if(book[to]) continue;
book[to] = 1;
if(match[to] == 0 || Find(match[to]))
{
match[to] = x;
return 1;
}
}
return 0;
}
int main()
{
while(~scanf("%d", &n), n)
{
memset(idx, 0, sizeof(idx));
memset(idy, 0, sizeof(idy));
memset(match, 0, sizeof(match));
for(int i = 0; i < maxn; i++)
v[i].clear();
int cntx = 1, cnty = 1;
for(int i = 0; i < n; i++)
scanf(" %s", maze[i]);
for(int i = 0; i < n; i++)
{
int flag = 0, ok = 0;
for(int j = 0; j < n; j++)
{
if(maze[i][j] == '.')
idx[i][j] = cntx, flag = 0, ok = 1;
if(maze[i][j] == 'X' && !flag && ok) cntx++, flag = 1;
}
if(!flag) cntx++;
flag = 0, ok = 0;
for(int j = 0; j < n; j++)
{
if(maze[j][i] == '.')
idy[j][i] = cnty, flag = 0, ok = 1;
if(maze[j][i] == 'X' && !flag && ok) cnty++, flag = 1;
}
if(!flag) cnty++;
}
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(maze[i][j] == '.')
{
v[idx[i][j]].push_back(idy[i][j]);
}
}
}
int ans = 0;
for(int i = 1; i <= cntx; i++)
{
memset(book, 0, sizeof(book));
ans += Find(i);
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: