您的位置:首页 > 运维架构

poj 3258 River Hopscotch(二分法,最小值最大化)

2017-07-08 08:42 405 查看

River Hopscotch

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2

2

14

11

21

17

Sample Output

4

ps:二分枚举最短距离

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int pos[50010];

int main()
{
int l,n,m;
scanf("%d%d%d",&l,&n,&m);
int low=l,high=l;
for(int i=1; i<=n; ++i)
scanf("%d",&pos[i]);
pos[n+1]=l;
sort(pos,pos+n+2);
for(int i=1; i<=n+1; ++i)
if(low>pos[i]-pos[i-1])
low=pos[i]-pos[i-1];
while(low<=high)
{
int mid=(low+high)>>1;//枚举最短距离
int cnt=0,sum=0;
for(int i=1; i<=n+1; ++i)
{
if((sum+=pos[i]-pos[i-1])<=mid)
++cnt;
else
sum=0;
}
if(cnt<=m)
low=mid+1;
else
high=mid-1;
}
printf("%d\n",low);
return 0;
}


参考博客:

ζёСяêτ - 小優YoU
Non_Cease

ps:这类题好像都是二分枚举答案啊,其他方法根本无从下手。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: