您的位置:首页 > 其它

PAT (Advanced Level) Practise 1074 Reversing Linked List (25)

2017-07-07 16:39 435 查看


1074. Reversing Linked List (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist
to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1


题意:给你一个链表的头,让你每隔k个节点倒置一下节点

解题思路:模拟,这题好像比较坑的一点是不一定是一个链表

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

struct node
{
int val,nt;
}a[100009];

int s,n,k,x,ans[100009],cnt;

int main()
{
while(~scanf("%d%d%d",&s,&n,&k))
{
for(int i=1;i<=n;i++) scanf("%d",&x),scanf("%d%d",&a[x].val,&a[x].nt);
cnt=0;
for(int i=s;~i;i=a[i].nt) ans[cnt++]=i;
for(int i=0;i+k<=cnt;i+=k)
{
for(int j=0;j<=k;j++)
{
if(i+j>=i+k-j-1) break;
swap(ans[i+j],ans[i+k-j-1]);
}
}
for(int i=0;i<cnt;i++)
{
printf("%05d %d ",ans[i],a[ans[i]].val);
if(i==cnt-1) printf("-1\n");
else printf("%05d\n",ans[i+1]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: