您的位置:首页 > 其它

hdu 1312 Red and Black

2017-07-07 14:12 302 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20353 Accepted Submission(s): 12404


[align=left]Problem Description[/align]
There
is a rectangular room, covered with square tiles. Each tile is colored
either red or black. A man is standing on a black tile. From a tile, he
can move to one of four adjacent tiles. But he can't move on red tiles,
he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

[align=left]Input[/align]
The
input consists of multiple data sets. A data set starts with a line
containing two positive integers W and H; W and H are the numbers of
tiles in the x- and y- directions, respectively. W and H are not more
than 20.

There are H more lines in the data set, each of which
includes W characters. Each character represents the color of a tile as
follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

[align=left]Output[/align]
For
each data set, your program should output a line which contains the
number of tiles he can reach from the initial tile (including itself).

[align=left]Sample Input[/align]

6 9

....#.

.....#

......

......

......
......

......

#@...#
.#..#.

11 9

.#.........
.#.#######.
.#.#.....#.

.#.#.###.#.
.#.#..@#.#.

.#.#####.#.
.#.......#.
.#########.
...........
11 6

..#..#..#..

..#..#..#..
..#..#..###

..#..#..#@.

..#..#..#..
..#..#..#..

7 7

..#.#..
..#.#..
###.###

...@...

###.###

..#.#..

..#.#..
0 0

[align=left]Sample Output[/align]

45

59

6
13
题目大意
一个人站在'@'上,只能往'.'上走,且可以往四个方向上运动,问可以走几步,bfs搜索一下就可以了

//31ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
using namespace std;
typedef long long ll;
int n,m;
char a[22][22];
int vis[22][22];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
struct node{
int x,y;
}pos,ans;
queue<node>que;
int bfs(int x,int y,int n,int m)
{
memset(vis,0,sizeof(vis));
queue<node>q;
int cnt=1;
pos.x=x;
pos.y=y;
vis[x][y]=1;
q.push(pos);
while(!q.empty())
{
pos=q.front();
q.pop();
for(int i=0;i<4;i++)
{
int xx=pos.x+dir[i][0];
int yy=pos.y+dir[i][1];
if(xx>=0 && xx<n && yy>=0 && yy<m && a[xx][yy]=='.' && vis[xx][yy]==0)
{
ans.x=xx;
ans.y=yy;
vis[xx][yy]=1;
cnt++;
q.push(ans);
}
}
}
return cnt;
}
int main()
{
while(scanf("%d%d",&m,&n)&&(n!=0 && m!=0))
{
int x,y;
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
cin>>a[i][j];
if(a[i][j]=='@')
{
x=i;
y=j;
}
}
}
printf("%d\n",bfs(x,y,n,m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: