您的位置:首页 > 其它

Distinct Substrings SPOJ - DISUBSTR 后缀数组(计算不同的子串数目)

2017-07-07 13:12 447 查看
Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;

Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:

2

CCCCC

ABABA

Sample Output:

5

9

Explanation for the testcase with string ABABA:

len=1 : A,B

len=2 : AB,BA

len=3 : ABA,BAB

len=4 : ABAB,BABA

len=5 : ABABA

Thus, total number of distinct substrings is 9.

首先所有的子串数目肯定是 n+n-1+n-2+…+1 因为就是依次固定起点和终点嘛。

然后需要理解一句话,所有的子串都是后缀的前缀。

所以 所有子串的数目就是所有后缀的长度和。就相当于固定起点和终点的道理一样,

然后每个height 代表最长的公共子串长度 所以只要减掉就好 就相当于 算

因为去掉前面的还剩下

n-sa[i] 个子串(因为在sa[i] 里面是每个串的起始下标(从0开始)),再剪掉重复的 height,就能得到剩下的

全部加起来就好。

#include <bits/stdc++.h>
using namespace std;

const int MAXN =1010;
int t1[MAXN],t2[MAXN],c[MAXN];

bool cmp(int *r,int a,int b,int l)
{
return r[a]==r[b]&&r[a+l]==r[b+l];
}

void da(char str[],int sa[],int ra[],int height[],int n,int m)
{
n++;
int i,j,p,*x=t1,*y=t2;
for(i=0;i<m;i++) c[i]=0;
for(i=0;i<n;i++) c[x[i]=str[i]]++;
for(i=1;i<m;i++) c[i]+=c[i-1];
for(i=n-1;i>=0;i--) sa[--c[x[i]]]=i;
for(j=1;j<=n;j<<=1)
{
p=0;
for(i=n-j;i<n;i++) y[p++]=i;
for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
for(i=0;i<m;i++) c[i]=0;
for(i=0;i<n;i++) c[x[y[i]]]++;
for(i=1;i<m;i++) c[i]+=c[i-1];
for(i=n-1;i>=0;i--) sa[--c[x[y[i]]]]=y[i];
swap(x,y);
p=1;x[sa[0]]=0;
for(i=1;i<n;i++)
x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
if(p>=n) break;
m=p;
}
int k=0;
n--;
for(i=0;i<=n;i++) ra[sa[i]]=i;
for(i=0;i<n;i++)
{
if(k) k--;
j=sa[ra[i]-1];
while(str[i+k]==str[j+k])k++;
height[ra[i]]=k;
}
}
int n;
int ra[MAXN],height[MAXN];
int sa[MAXN];
char str[MAXN];
bool ok(int ans,int n,int k)
{
int i=1;
while(i<n)
{
int j=i+1,cnt=0;
while(j<=n&&height[j]>=ans)
{
cnt++;
j++;
}
if(cnt>=k-1) return true;
i=j;
}
return false;
}

int main()
{
int t;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%s",str);
n=strlen(str);
str
=0;
da(str,sa,ra,height,n,256);
long long ans=0;
for(int i=1;i<=n;i++)
{
ans=ans+n-sa[i]-height[i];
}
printf("%lld\n",ans );
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: