您的位置:首页 > 理论基础

湖南省第十二届大学生计算机程序设计竞赛 Parenthesis

2017-07-06 23:40 375 查看


Description

Bobo has a balanced parenthesis sequence P=p1 p2…pn of
length n and q questions.
The i-th question is whether P remains balanced after pai and pbi  swapped.
Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists balanced parenthesis sequence A,B such that S=AB;
3. or there exists balanced parenthesis sequence S' such that S=(S').


Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤105,1≤q≤105).
The second line contains n characters p1 p2…pn.
The i-th of the last q lines contains 2 integers ai,bi (1≤ai,bi≤n,ai≠bi).


Output

For each question, output "Yes" if P remains balanced, or "No" otherwise.


Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2



Sample Output

No
Yes
No



Hint


Source

湖南省第十二届大学生计算机程序设计竞赛

想法:

关键读懂题意

根据合法括号的定义,(总是要比)多或者相等,就是说,前缀和必须总是>=0(对于每一个位置必须都要>=0, 最后一个必须等于0。
代码:

#include<stdio.h>

#include<string.h>

#define M 100001

int a[M],b[M];

char s[M];

int i,j,k,n,m,q;

void swap(int &a,int &b)

{

    int t;

    t=a;

    a=b;

    b=t;

}

int main()

{

    while(~scanf("%d%d",&n,&q))

    {

        scanf("%s",s);

        for(i=0;i<n;i++)

        {

            if(s[i]=='(')a[i+1]=1;

            else a[i+1]=-1;

            b[i+1]=b[i]+a[i+1];

        }

        for(i=0;i<q;i++)

        {

            int x,y;

            scanf("%d%d",&x,&y);

            if(a[x]==a[y])

            {

                printf("Yes\n");

                continue;

            }

            if(x>y)//让x<y

            swap(x,y);

            bool flag=1;

            int ans=b[x-1];

            ans+=a[y];

            if(ans<0)flag=0;//换后,到原x位置是否平衡

            else

            {

            for(j=x+1;j<y;j++)//换后,原x+1到原y-1位置中所有位置上是否平衡

            {

                ans+=a[j];

                if(ans<0){flag=0;break;}

            }

            ans+=a[x];

            if(ans<0)flag=0;//到原y位置上是否平衡

            }

            if(flag)printf("Yes\n");

            else printf("No\n");

        }

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐