您的位置:首页 > 其它

PAT甲级 1027. Colors in Mars (20)

2017-07-05 22:38 501 查看

1027. Colors in Mars (20)

时间限制
400 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only
difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the
left.

Sample Input
15 43 71

Sample Output
#123456


#include <iostream>
#include <algorithm>
#include<string.h>
#include<cstdio>
using namespace std;

void trans(int n)
{
char s[3];
int cnt=0;
while(n!=0)
{
s[cnt++]=n%13;
if(s[cnt-1]<10) s[cnt-1]+='0';
else s[cnt-1]=s[cnt-1]-10+'A';
n/=13;
}
if(cnt==0)
{
s[0]='0';
s[1]='0';
}
if(cnt==1)
{
s[1]='0';
}
cout<<s[1]<<s[0];
}

int main()
{
int n1,n2,n3;
cin>>n1>>n2>>n3;
cout<<"#";
trans(n1);
trans(n2);
trans(n3);
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: