您的位置:首页 > 其它

PAT (Advanced Level) Practise 1083 List Grades (25)

2017-07-05 20:16 537 查看


1083. List Grades (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:
N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name
ID
grade

grade1 grade2


where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is
no student's grade in that interval, output "NONE" instead.
Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:
NONE


题意:给出n个人的名字,id和分数,问在一个分数段里的有哪些人,按字典序输出

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <functional>
#include <climits>

using namespace std;

#define LL long long
const int INF = 0x7FFFFFFF;

char name[100009][25],id[100009][25];
int score[100009];
int n, l, r;
vector<int> ans;

bool cmp(const int &x, const int&y)
{
return score[x] > score[y];
}

int main()
{
while (~scanf("%d", &n))
{
ans.clear();
for (int i = 0; i < n; i++) scanf("%s%s%d", name[i], id[i], &score[i]);
scanf("%d%d", &l, &r);
for (int i = 0; i < n; i++)
if (score[i] >= l&&score[i] <= r) ans.push_back(i);
sort(ans.begin(), ans.end(), cmp);
if (ans.size())
{
for (int i = 0; i < ans.size(); i++)
printf("%s %s\n", name[ans[i]], id[ans[i]]);
}
else printf("NONE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: