您的位置:首页 > 其它

PAT (Advanced Level) Practise 1081 Rational Sum(20)

2017-07-05 20:07 525 查看


1081. Rational Sum (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number,
then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional
part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:
3 1/3

Sample Input 2:
2
4/3 2/3

Sample Output 2:
2

Sample Input 3:
3
1/3 -1/6 1/8

Sample Output 3:
7/24


题意:给你n个分数,求出它们的和

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL a[105], b[105];
int n;

LL gcd(LL x, LL y)
{
if (x > y) swap(x, y);
while (y%x)
{
LL k = y%x;
y = x;
x = k;
}
return x;
}

int main()
{
while (~scanf("%d", &n))
{
for (int i = 1; i <= n; i++) scanf("%lld/%lld", &a[i], &b[i]);
LL ans1=0,ans2=1;
for (int i = 1; i <= n; i++)
{
LL k = gcd(ans2, b[i]);
ans2 = b[i] * ans2 / k;
}
for (int i = 1; i <= n; i++) ans1 += ans2 / b[i] * a[i];
if (!ans1) { printf("0\n"); continue; }
LL x = abs(ans1);
LL k = gcd(x, ans2);
ans1 /= k, ans2 /= k;
if (ans1%ans2 == 0) printf("%lld\n", ans1 / ans2);
else
{
if (abs(ans1) < ans2) printf("%lld/%lld\n", ans1, ans2);
else
{
if (ans1 > 0) printf("%lld %lld/%lld\n", ans1 / ans2, ans1%ans2, ans2);
else printf("%lld -%lld/%lld\n",(LL)(ans1 / ans2), abs(ans1)%ans2, ans2);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: