您的位置:首页 > 其它

poj3335-Rotating Scoreboard 判断多边形是否有内核(模板题)

2017-07-04 16:21 417 查看
Rotating Scoreboard

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7108 Accepted: 2845
Description

This year, ACM/ICPC World finals will be held in a hall in form of a simple polygon. The coaches and spectators are seated along the edges of the polygon. We want to place a rotating scoreboard somewhere in the hall such that a spectator sitting anywhere
on the boundary of the hall can view the scoreboard (i.e., his line of sight is not blocked by a wall). Note that if the line of sight of a spectator is tangent to the polygon boundary (either in a vertex or in an edge), he can still view the scoreboard. You
may view spectator's seats as points along the boundary of the simple polygon, and consider the scoreboard as a point as well. Your program is given the corners of the hall (the vertices of the polygon), and must check if there is a location for the scoreboard
(a point inside the polygon) such that the scoreboard can be viewed from any point on the edges of the polygon.

Input

The first number in the input line, T is the number of test cases. Each test case is specified on a single line of input in the form n x1 y1 x2 y2 ... xn yn where n (3
≤ n ≤ 100) is the number of vertices in the polygon, and the pair of integersxi yi sequence specify the vertices of the polygon sorted in order.

Output

The output contains T lines, each corresponding to an input test case in that order. The output line contains either YES or NO depending on whether the scoreboard can be placed inside the hall conforming to the problem conditions.

Sample Input
2
4 0 0 0 1 1 1 1 0
8 0 0  0 2  1 2  1 1  2 1  2 2  3 2  3 0

Sample Output
YES
NO

题目大意,给你一些坐标,问这些坐标构成的多边形有没有内核

直接套用模板就可以了
ac代码如下(模板)
//poj3335
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;

const double eps = 1e-8;
const int maxn = 105;

int dq[maxn], top, bot, pn, order[maxn], ln;
struct Point {
double x, y;
} p[maxn];

struct Line {
Point a, b;
double angle;
} l[maxn];

int dblcmp(double k) {
if (fabs(k) < eps) return 0;
return k > 0 ? 1 : -1;
}

double multi(Point p0, Point p1, Point p2) {
return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}

bool cmp(int u, int v) {
int d = dblcmp(l[u].angle-l[v].angle);
if (!d) return dblcmp(multi(l[u].a, l[v].a, l[v].b)) < 0;
return d < 0;
}

void getIntersect(Line l1, Line l2, Point& p) {
double dot1,dot2;
dot1 = multi(l2.a, l1.b, l1.a);
dot2 = multi(l1.b, l2.b, l1.a);
p.x = (l2.a.x * dot2 + l2.b.x * dot1) / (dot2 + dot1);
p.y = (l2.a.y * dot2 + l2.b.y * dot1) / (dot2 + dot1);
}

bool judge(Line l0, Line l1, Line l2) {
Point p;
getIntersect(l1, l2, p);
return dblcmp(multi(p, l0.a, l0.b)) > 0;
}

void addLine(double x1, double y1, double x2, double y2) {
l[ln].a.x = x1; l[ln].a.y = y1;
l[ln].b.x = x2; l[ln].b.y = y2;
l[ln].angle = atan2(y2-y1, x2-x1);
order[ln] = ln;
ln++;
}

void halfPlaneIntersection() {
int i, j;
sort(order, order+ln, cmp);
for (i = 1, j = 0; i < ln; i++)
if (dblcmp(l[order[i]].angle-l[order[j]].angle) > 0)
order[++j] = order[i];
ln = j + 1;
dq[0] = order[0];
dq[1] = order[1];
bot = 0;
top = 1;
for (i = 2; i < ln; i++) {
while (bot < top && judge(l[order[i]], l[dq[top-1]], l[dq[top]])) top--;
while (bot < top && judge(l[order[i]], l[dq[bot+1]], l[dq[bot]])) bot++;
dq[++top] = order[i];
}
while (bot < top && judge(l[dq[bot]], l[dq[top-1]], l[dq[top]])) top--;
while (bot < top && judge(l[dq[top]], l[dq[bot+1]], l[dq[bot]])) bot++;
}

bool isThereACore() {
if (top-bot > 1) return true;
return false;
}
int main()
{
int t, i;

scanf ("%d", &t);
while (t--) {
scanf ("%d", &pn);
for (i = 0; i < pn; i++)
scanf ("%lf%lf", &p[i].x, &p[i].y);
for (ln = i = 0; i < pn-1; i++)
addLine(p[i].x, p[i].y, p[i+1].x, p[i+1].y);
addLine(p[i].x, p[i].y, p[0].x, p[0].y);
halfPlaneIntersection();
if (isThereACore()) printf ("YES\n");
else printf ("NO\n");
}
return 0;
}


题面样例过不掉,但提交上去还是ac了,不明所以。
题目链接:点击打开链接http://poj.org/problem?id=3335

下面还有一个n^2的算法
#include <math.h>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi=acos(-1.0);
const double e=exp(1.0);
const double eps=1e-8;
const int maxn=105;

struct Point{
double x,y;
}point[maxn];

Point temp[maxn];
Point p[maxn];
int pre_point ,last_point;
double a,b,c;

void getline(Point x,Point y)//获取直线ax+by+c==0
{
a=y.y-x.y;
b=x.x-y.x;
c=y.x*x.y-x.x*y.y;
}

Point intersect(Point x,Point y)//获取直线ax+by+c==0 和点x和y所连直线的交点
{
double u=fabs(a*x.x+b*x.y+c);
double v=fabs(a*y.x+b*y.y+c);
Point ans;
ans.x=(x.x*v+y.x*u)/(u+v);
ans.y=(x.y*v+y.y*u)/(u+v);
return ans;
}

void cut()//用直线ax+by+c==0切割多边形
{
int cut_num=0;
for(int i=1; i<=last_point; ++i)
{
if(a*p[i].x+b*p[i].y+c>=0){
temp[++cut_num]=p[i];
}
else
{
if(a*p[i-1].x+b*p[i-1].y+c>0)
{
temp[++cut_num]=intersect(p[i-1],p[i]);
}
if(a*p[i+1].x+b*p[i+1].y+c>0)
{
temp[++cut_num]=intersect(p[i+1],p[i]);
}
}
}
for(int i=1; i<=cut_num; ++i)
{
p[i]=temp[i];
}
p[cut_num+1]=temp[1];
p[0]=temp[cut_num];
last_point=cut_num;
}

void solve()
{
for(int i=1; i<=pre_point; ++i){
p[i]=point[i];
}
point[pre_point+1]=point[1];
p[pre_point+1]=p[1];
p[0]=p[pre_point];
last_point=pre_point;
for(int i=1; i<=pre_point; ++i)
{
getline(point[i],point[i+1]);//根据point[i]和point[i+1]确定直线ax+by+c==0
cut();//用直线ax+by+c==0切割多边形
}
}
int main()
{
int tot=1;
while(cin>>pre_point&&pre_point){
for(int i=1; i<=pre_point; ++i){
cin>>point[i].x>>point[i].y;
}
solve();
printf("Floor #%d\n",tot++);
if(last_point==0) puts("Surveillance is impossible."),puts("");
else puts("Surveillance is possible."),puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: